Numéros de ligne en signature

Un problème ? Une remarque concernant le site ? Venez en parler ici !
Mixture
 
Messages: 280
Inscription: Sam 13 Aoû 2011 20:50
Localisation: Gif-sur-Yvette (91)
Bonjour,

Certains utilisateurs mettent en signature de leurs messages les lignes de bus empruntées ou dont ils assurent le service, ou discutent directement dans le message de plusieurs lignes de bus (par exemple à l'occasion de modifications temporaires de parcours). Ces indices proviennent de la base Siloé, et semblent être appelés à la volée, pour chaque message de chaque page de discussion.

Depuis quelques semaines, il devient pénible de consulter les discussions dont les utilisateurs utilisent beaucoup d'indices. Sur mon Mac, sous Safari, cela se traduit par le blocage de la page visualisée tant que tous les indices n'ont pas été chargés depuis Siloé (impossible de descendre dans la page). C'est suffisamment pénible pour que j'arrête de consulter certaines discussions dont je sais qu'elles contiennent beaucoup d'indices, soit parce que le sujet s'y prête (modification de l'année 2018), soit parce que le dernier intervenant est connu pour mettre en signature une vingtaine d'indices de lignes.

Suis-je le seul ?

Avatar de l’utilisateur
Asso BusParisiens
yves_de_paris
Asso BusParisiens
 
Messages: 2996
Inscription: Mer 7 Juil 2010 21:11
Localisation: Paris 19ème
Non, çà me le fait aussi !

Daniel Tilliet avait fait une remarque à ce sujet, et qui est restée sans effets !
Visitez ce site : http://www.parimagine.fr

Avatar de l’utilisateur
Yann
Administrateur du site
 
Messages: 3508
Inscription: Jeu 8 Juil 2010 23:49
Localisation: Ozoir-la-Ferrière (77)
Bonjour,

petites précisions :
- l'utilisation de ces indices appelle une page php, ultra-simple, qui affiche effectivement à la volée à chaque fois l'image et le lien
- ces vignettes sont hébergés sur le même serveur que le forum, et les liens dirigent vers Siloé.
- les images pèsent entre 500 octets et 3 Ko, donc même une centaine d'indices pèse moins d'1 Mo !

Ce n'est donc pas le téléchargement de ces images qui ralentit vos connexions, mais plus probablement le traitement de toutes les pages php dans vos navigateurs.
Personnellement, je n'ai jamais rencontré de lenteurs à ce niveau là, mais bien dans les pages qui contiennent beaucoup de photos.

Yann :wink:
"Happiness only real when shared" Chris McCandless
"Ma religion, c'est l'amour" Guy Gilbert

Avatar de l’utilisateur
Yann
Administrateur du site
 
Messages: 3508
Inscription: Jeu 8 Juil 2010 23:49
Localisation: Ozoir-la-Ferrière (77)
Mixture a écrit:Sur mon Mac, sous Safari, cela se traduit par le blocage de la page visualisée tant que tous les indices n'ont pas été chargés depuis Siloé (impossible de descendre dans la page).


Je viens de tester sur mon Mac au boulot avec Safari (que j'utilise très rarement), je n'ai vu aucune différence avec Firefox, l'affichage des indices est quasi instantané.
Je regarderai ce soir chez moi, où j'ai une version plus ancienne de MacOSX (10.6.8 contre 10.10.5 ici) et qui me joue des tours avec quelques sites.

Yann :wink:
"Happiness only real when shared" Chris McCandless
"Ma religion, c'est l'amour" Guy Gilbert

Avatar de l’utilisateur
JM-C
Administrateur du site
 
Messages: 6856
Inscription: Mar 6 Juil 2010 12:45
Localisation: Lyon / Paris
Je pense que certains abusent, il n'est pas nécessaire de mettre un centre-bus complet, ça n'a d'ailleurs aucune raison d'être.
De plus quelle idée d'aller chercher dans Siloé plutôt que dans BP directement ? ça rajoute chaque fois une URL puisque c'est un autre domaine.

Mixture
 
Messages: 280
Inscription: Sam 13 Aoû 2011 20:50
Localisation: Gif-sur-Yvette (91)
Yann a écrit:Bonjour,

petites précisions :
- l'utilisation de ces indices appelle une page php, ultra-simple, qui affiche effectivement à la volée à chaque fois l'image et le lien
- ces vignettes sont hébergés sur le même serveur que le forum, et les liens dirigent vers Siloé.
- les images pèsent entre 500 octets et 3 Ko, donc même une centaine d'indices pèse moins d'1 Mo !

Ce n'est donc pas le téléchargement de ces images qui ralentit vos connexions, mais plus probablement le traitement de toutes les pages php dans vos navigateurs.
Personnellement, je n'ai jamais rencontré de lenteurs à ce niveau là, mais bien dans les pages qui contiennent beaucoup de photos.

Yann :wink:


Bonjour, merci Yann pour ces précisions. Les images ne pèsent effectivement rien.

Pourtant, quelle que soit la connexion testée, les pages avec beaucoup d'indices (signatures ou contenu du message) bloquent pendant plusieurs secondes le navigateur Safari. Je reconnais que sous Chrome, cela ne le fait pas. Sous Firefox, ce n'est pas immédiat, mais moins long quand même que sous Safari, et le ventilateur se déclenche...

Pour les pages avec photos, cela dépend du poids des image. Celles de Pacificelectric se chargent toujours facilement. Les pages avec des photos qui pèsent plusieurs Mo par fichier sont plus longues à charger.


Retourner vers Support technique

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 non inscrits